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Introduction 
Viewplot is various file viewer/translator and editor for PCB related purpose. 
Several CAD formats can be loaded and translated as Gerber (D and 274X),  
Drill, HPGL and Auto-cad DXF. 
Viewplot can read all 274X data including macros repeat functions etc.  
Output formats are DXF, Gerber, HPGL and PDF format. 
The PDF output format is real representation from the Gerber input data and is  
written in fully Ascii. 
This results in a high-resolution file with a small file size. (Can be zipped to 70-90%) 
Manipulating from the data, or adding addition information make simple adjustments in  
Gerber data. 
 
Viewplot is a easy to use piece of software, The viewer is Completely Free of  
charge. Viewplot can be used and shared by anyone needing to (re)view electronics  
design and or manufacturing data.  
By combining all the input files needed for manufacturing or (re)view in one complete  
Job file, Viewplot easily transfers work from design to colleagues for review or to fabrication. 
 
Viewplot main purpose is to Translate Gerber directly to PDF, this can be done in batch 
mode or within the GUI. 
Translate mechanical board information (DXF) to Gerber or even to a Ample �do_file�  which 
can be load in the Mentor Graphics Board-Station Librarian (Additional Userware provided). 
 

Files required for using the demonstration guide 
All files required for the demonstration guide are include in the demonstration_guide.zip 
Compressed file. With the following dir structure  
./274-D_Gerber  
./274-X_Gerber  
./DXF  
./job  
./Mentor 
 
 

Ordering Information 
Viewplot can be down-loaded from the Roneda website, www.roneda.nl 
The down-load version is a Viewer only, if you want to manipulate gerber data translate and 
save data, a valid license key is required.  
For purchasing Viewplot contact Roneda.  
We will provide you with the license file and USB key. 
 
If you have any question and or feedback concerning the Viewplot software don�t hesitate to 
Contact us at viewplot@roneda.nl 
 
For more information, contact: 
 
Roneda PCB Design Consultancy  
The Netherlands 
Fax: +31 (0)53 8 50 04 18 
Tel: Netherlands: +31 (0)650 227 965 
Tel: Belgium: +32 (0)485 802 404  
viewplot@roneda.nl 
www.roneda.nl 

mailto:viewplot@roneda.nl?subject=Info Roneda PCB Design Consultancy
mailto:viewplot@roneda.nl
http://www.roneda.nl/
Viewplot Manual
Viewplot Viewer, can save input data to the internal Job file format.
(.Job) to share or review data. (Free)
For saving & Translating input data formats a license key is required.

Viewplot Manual
Job file: Viewplot Internal file format.

Viewplot Manual
 Viewplot Viewer, can save input data to the internal Job file format.
(.Job) to share or review data. (Free)
For saving & Translating input data formats a license key is required.
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Graphical User Interface 
 

 
 
Viewplot uses the standard Windows interface. Menus, toolbars, and other 
interface features follow Windows standards. 
 

• Title-bar � This contains the path to the active layer file. 
• Pull-down Menus � Standard pull-down menu system. 
• Toolbar � These offer quick access to the common Viewplot commands. 
• Active Layer � Select active layer(Working layer) by a list-box. 
• Absolute position � Coordinate readout for the cursor location, in mm. 
• Absolute grid position � Absolute grid readout for the cursor location,  

in Inch,mils,mm or Hpgl. 
• Relative (grid) position � relative grid readout for the cursor location,  

in Inch,mils,mm or Hpgl. 
• Status-bar � Provides status, and other user information. 
• Workspace � Area for displaying the design data. This area can be enlarged, 

reduced, or zoomed. 
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Chapter 1: Navigation 
 

Loading a Job file 
Viewplot saves data in it�s internal format *.job 
This binary format allows information to be easily transferred. A Job file can contain 
Gerber, DXF and Hpgl data , layer names, aperture lists, drill files, editing changes.  
 
We have already loaded the raw Gerber data files for you and saved 
the information in a Job file � later lessons will deal with loading many different types of 
Gerber, Auto-cad DXF and Drill data. 
 
First we will learn the major areas of the software by loading a Job file and performing some 
simple tasks. 
 
1. Start Viewplot 
2. From the main menu choose File > Load job or {F4} from the ./job dir. 
3. Use the navigator to navigate and select the �Navigate.job� file, then select Open 
 
A graphical representation of the physical board appears on the screen (See Figure 1). 
 

 
Figure 1: Loaded �navigate.job� Data 
 

Saving 
Any changes made to the Job can be saved by selecting File > Save job or {Shift F4}  
Use the navigator to navigate and select the current job file, or input a new File_name, 
and select Save 
 
Note:  default extension from the job file is *.job 

For saving data you need a valid license key. (See Ordering information) 
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Navigation: Zoom 
To enlarge or reduce an area of the board for better viewing. 
Viewplot supports the following zoom features. 
 
1. Click on the Maximize button to maximize the current Viewplot window, or resize the  
    window  manually.  
2. Click the right mouse button to obtain a list of view options and choose:  

Zoom in/Out, 
    View whole design and or Previous view (See Figure 2). 
  
   Note: Or use the hotkey z,Z,F8 and v 
 

 
Figure 2: Right mouse button menu 
 
3. To zoom in, drag a window with your left mouse button +Ctrl key pressed down, around the   
    area you wish to investigate (Starting from Upper left window). 
4. To zoom out, click the right mouse button and select the Zoom Out {Z} option or, 
    use the previous function, but now (Starting from Lower right window). 
    The none-changing rectangle visible is the border of your design. The changing rectangle  
     is the  zoom-out window. 
5. To zoom to the previous zoom level, click the right mouse button and select the  
    Previous view option. 
6. All Zoom features can also be located under View Pull-down Menu along with current 
    hotkey settings. 
7. When finished, choose View whole view {F8} to fit the design to page. 
 
 

View/Hide Layer Information 
The Viewable objects window  contains information about all layer and objects in the Job file.  
Layers are divided into different data types. (See Figure 3) 
 
1. Drill Holes � These layers represent any Drill holes information. 
2. Gerber Layers � These layers represent the physical layers of the board 
3. DXF Layers � These layers can consist mechanical board information. 
4. Hpgl Layers � These layers can consist mechanical board information. 
 
Layers can be enabled or disabled for viewing, by clicking the layer in the Layers list. 
From View > viewable objects or {Ctrl A} 
Select the Deselect All to hide, or the Select All button for viewing all layers in the graphical 
window. 
 

 
Figure 3: Viewable objects window 
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The other layer objects can be viewed by clicking the corresponding check boxes. 
Experiment with following options. 
 
1. De-select the drill object with the Drill option  button,  
   The drill holes will disappear from the graphical window. 
2. De-select the Pads or Traces object with the Pads/Traces option  button,  
   The Pads, traces will disappear from the graphical window. 
3. De-select the Filled objects from the Filled objects button, 
    Filled objects as Pads & Polygons will be shown as hollow objects. 
4. De-select the Colors merged or solid from the Colors merged objects button, 
    Overlapping layers will not use merged colors or solid in the graphical window.  
5. Show only active layer option, Only the active layer will be visible, Step through the design 
    by pressing the space-bar or use the �Active Layer� list-box. 
 

Selecting Data 
Many functions within Viewplot work with data that has been selected.  
Without affecting the other data on the layer. 
Selection of data can only occur on the active layer. 
Some methods of selecting data. 
 
1. First set Layer L1 �Bottom.ger� as active(working) layers (see Figure 4). 
 
RMB > Select All. The data should turn in White indicating that the data is selected. 
 

 
Figure 4: Set  active Layer 
 
 
2. Zoom in on a selected area (see previous sections for how to zoom in) and we will 
   experiment with unselecting and reselecting data. 
  
   Holding down the Shift button and use the LMB to deselect a currently selected objects.  
   You can reselect the objects by using the left mouse button again. 
 
3. Select by a left mouse button click on an object, or drag a window. 
    After several selection actions, Refresh the Workspace window by RMB > Repaint {F5} 
 
4. By selecting with the left mouse button without the Shift key will deselect all data previous    
    selected. This method ensures that the selected data are the only object(s) selected. 
 
Note: two-selection mode are available: Append and Replace selection (Default) 
         Select the option from the Edit Pull-down menu. 
 
5. To unselect all selected data choose RMB > Deselect All. 
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Query and Status Bar 
It is useful to know some information about an object such as D-Code, Size, Type, 
and position. Viewplot provides that information in a quick and easy-to-understand way. 
 
1. Select the object(s) that you wish to investigate. 
    And report the selected objects by RMB > Info selected objects or simply press {i}. 
    A message window will pop-up and report all relevant information (See Figure 5) 
  
2. Information about the objects including Layer, Aperture size and Shape, Position and other   
    useful information is displayed. 
    Information can be copied to clipboard for further (Re)use in Viewplot or other programs.  
 
Note: The information varies with the type of object being investigated (Pad v Trace v Drill 
etc) 
 

 
Figure 5: Info selected objects 
 
3. Multiple items can be reported in the same window, Select all objects by RMB > Select All 
    and press i. A message will pop-up to warn you about the amount of selected objects. 
    Select the OK button to report the selected objects. (This can take some time) 
 
4. Select specific apertures only. Select all objects first, as before. 
    RMB > Selection only objects with apertures, a �select aperture� list, will popup 
    With all apertures from the selected objects. (See Figure 6) 
 

 
Figure 6: Select aperture list 
 
Select aperture D-code 220 and press ok. Only objects with D-code 220 are now selected. 
If you can�t see the selected objects in your current working-space, 
Press I to report the object(s), Find out how many objects are selected and where they 
located. 
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Copy one of the coordinates to the clipboard by {Ctrl C}. 
 
Select function Edit > Goto x,y location and paste the coordinates to the pop-up window. 
Viewplot will now zoom in on this coordinate. (See Figure 7) 
  

      
Figure 7: The Report Window, and Copy to X,Y Location  
 
5. Features such as Zoom In and Zoom Out can also be used to navigate during a selection. 
 
6. You can now Close this Job (without saving) in preparation for loading the 
    Gerber files from the next Chapter, Select File > Clear all layers and select option No for    
    save. Choose File > Exit to quite the Viewplot program. (See Figure8) 
 
 

 
Figure 8: File > Clear all layers or Exit 
 
 
 
 



Viewplot The Gerber Viewer Translator 
 

 

Viewplot Demo guide Roneda PCB Design Consultancy 11 

Chapter 2: Loading Gerber and other data 

Loading Gerber data 
The data we will use to illustrate some of the loading features of Viewplot 
includes RS-274-X files (Extended Gerber), RS-274-D files with 
aperture lists that convert automatically, an aperture list that needs manual conversion, and 
drill data.  
 
Gerber data will normally arrive in a consistent format for each job, the data for this lab is 
meant to illustrate each of the file formats and technique to load them into Viewplot.  
We only cover the most common techniques to load gerber or other data for 
More detailed information see the Viewplot manual. 
 
1. From the menu choose File >Load Files {F3}  
    Navigate to the directory where the demonstration data is stored, and select: 
    by using the Control button and/or Shift button: following files from the Sub directory 
    ./274-D_Gerber. (See Figure9) 
 

    - Top.ger RS-274-D gerber 
    - Bottom.ger RS-274-D gerber 
    - Gerber.apt aperture list for gerbers files from above. 

 

 
Figure 9: Load the 274-D Gerber files 
 
 
2. Hit the Open button when you have selected the required files. The program now    
    automatically recognizes file types and when possible the formats. 
    Viewplot will pop-up the �Read files� window which give you an overview from the selected 
    files.  
    If certain file types are not recognized by Viewplot, You can select the type manually from 
    the Drop down list. (See Figure10) 
  
   The destination layer can be chosen from the drop down list, We leave it as it is pre-defined    
   by Viewplot.  
 
   Note: To verify the ASCII file structure. Hit the View File button. 
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Figure 10: Read files window; Displays recognized file type and layer name 
 
 
3. If file formats are not recognized on the fly by Viewplot it will pop-up an �Assistant load� 
    window from where you can define the format interactively. 
     
4. Now the �Load apertures� window will pop-up. 
    Parameters can be easily updated if necessary, Enter the values from (Figure 11) 
    Or try the �Hint by program� button and hit the �Read aperture� button to proceed. 
    A pop-up message will inform you that 40 apertures have been found. 
 
Note: All parameters can be adjusted, as skip lines, Columns adjustment for:  
         D-code,Shape,X/Y size and units can be set. 
 

 
Figure 11: Load Apertures Assistant window 
 
 
5. A �load gerber file� window will pop-up after reading the apertures, with a preview 
    from the ASCII information from the corresponding file. Number format 
    suppression type and units can be chosen.  
    Enter the values (as shown in Figure 12) or simply use the �Hint by program� button  
    To find the correct parameters. (Repeat this step for the second gerber file) 
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Figure 12: Load Gerber Assistant window 
 
6. You will see the layers being created in the Viewplot working space.  
 
7. No we will load the drill data into Viewplot  in the same matter we did for 
      the gerber data. Select the drill file and press Ok. {F3} 

- Cdio.drl Drill file 
 

The �Load drill files� window pops-up as we saw on loading gerber data 
Use the �Hint by program� button or enter the values (as shown in Figure 13) 
 
 
 

  
Figure 13: Load Drill Assistant window 
 
8.  There will be a notification of missing tools: (The following tools do not exist T1�T5) 
     This because we did not load the tool table. 
     Viewplot is using a default drill size from 1mm for all drills instead. 
 
9.  Load the drill table (drills.rep) as we did with the other file types from above. 
 
10. Adjust the �Load drill tools� window (as shown in Figure 14) and hit the �Read drill tools� 
      button. 5 drill tools have been found as reported by a message box. 
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Figure 14: Load Drill tools Assistant window 
 
 
11. Viewplot will still recognize the previous loaded Drill data and will ask to Reload all 
      Drill layers, press the Ok button to proceed. (See Figure 15) 
      The drill holes will now have their correct size. 
 

Note: The same functionality can be used for Gerber data. 
 

 

 
Figure 15: Reload Drill  
 
 
12. The Drill information is displayed as a representation from the pad-size combined with  
      the drill size opening (See Figure 16). 
 

 
Figure 16: Both gerber layers including Drill holes 
 
13. The format information just entered can be memorized and re-used 
      on further use for aperture/drill files of this format by: Edit > gerber/drill Startup info 
      - Not covered by this demonstration (see Viewplot manual for more info) 
 
14. Viewplot can also load Auto-cad DXF and Hpgl file formats (See the samples in the  
      ./sample directory) You�re free to experiment with these files, to get more familiar with 
      these data types as well. 
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Chapter 3: Manipulate data 
The data we will use to illustrate some of the Edit features of Viewplot like 
( Move/Delete/Copy Measure and Oversize objects). Are RS-274-X files (Extended Gerber), 
so they can be loaded quickly, all files are stored in the ./274-X_Gerber directory. 
 

Aligning layers 
1. From the menu choose File >Load Files {F3}  
    Navigate to the directory where the demonstration data is stored, and select: 
    by using the Control button and/or Shift button: following files from the Sub directory 
    ./274-X_Gerber/Top-x.gbx & Bottom-x.gbx  
 
You will notice that the layers are miss-aligned. We will now move layer Top-x.gbx 
layer to align with the Bottom-x.gbx Gerber file. (See Figure 17) 
Viewplot allows the movement of individual objects and or entire layer sets. 
 

 
Figure 17: Layers with offset 
 
This section of the demonstration guide offsets the entire layer. 
 
2. First we have to investigate the offset between the 2 layers, 
    Select with a single mouse click Pad B, Switch to the other layer by 
    Pressing the space-bar. Now you can �Add� select Pad A. 
    To measure the distance between both pads simply select  
    RMB -> Measure distance between objects 
 
3. A message window will report a center distance from 2.25mm (See Figure 18). 
 

 
Figure 18: Measure distance report 
 
 
4. Deselect all objects by; RMB > Deselect all layers 
 
5. Select all object from layer �Top-x.gbx� with the RMB > Select All 
    All selected object will be colored white. 
 
6. The selected objects can be moved, use the move button from the Tool-bar or press {m} 
    Ones in the move mode, you can still zoom or pan around. 
    Move the layer around, the selected layer information is visible as a �ghost� image, 
    by changing from grid size {Ctrl g} and/or RMB > Snap on/off  functions the layer can be  
    placed on top of the �bottom� layer.   
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7. A better solution to offset the layer is by pressing the Space bar after selecting all layer 
    objects. 
    The �move objects� window will pop-up, here you can enter the new coordinates directly.  
    (See Figure 19) With a @ as first character, it will tread the coordinates as relative. 
    So just type: @2.25,0 and OK.  
    Both layers are now aligned, Refresh the window by {F5} 
    by repeating the steps 2 and 3, the center distance should be 0.0mm.     
 
 

   
Figure 19: Move objects Window 
 
 

Create a custom Solder-mask layer 
1. From the menu choose File >Load Files {F3}  
    Navigate to the directory where the demonstration data is stored, and select: 
    
    ./274-X_Gerber/Top-x.gbx 
 
We use the gerber data from the Top-x.gbx layer as basis for a custom made Solder-mask 
layer. 
You will find out how straightforward objects can be re-used for all kind of purpose within 
Viewplot. 
 
2. For the Solder-mask layer we should create a new gerber layer, Switch the active  
    layer to L1, by the Drop-down list or type {l}.  
    Choose File > New and select Gerber file, a new empty gerber file is now created. 
 
3. Switch the active layer back to L0 by pressing the Space bar. To select the Pad objects 
    only, set the viewable object to Pads only {Ctrl A} (See Figure 20) 
 
 

 
Figure 20: View Pads only 
  
 
4. Select all object from layer �Top-x.gbx� with the RMB > Select All 
    after that,  RMB > Copy to other layer Select Layer 1 as destination layer and OK. 
    All Pads are copied to the L1 layer, if you switch back to the default View mode   
    with option Merge colors, the window should look like (Figure 21). 
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Figure 21: View Top layer + New Pads on L1 
 
 
5. Normally the Solder-mask pads are a bit larger as the Copper pads, for this we 
    should oversize the pads. (For the Demo we using 0.2mm) 
    Select all objects from the Solder-mask layer as we did before and simply select 
    RMB > Oversize Fill in the form as shown in (Figure 22) & Ok. 
 
 

 
Figure 22: Oversize pop-up & the results window 
 
 
For following actions we need to re-generate the apertures from the Solder-mask layer. 
Viewplot will generate the new apertures if you save the gerber data  

Note: For saving data you need a valid license key.  
  If you don�t have a license key, use the ./ Soldermask-oversize.gbx data. 
 
6. To cover the Via holes with Solder-mask at PCB production, the Via Solder-mask pads 
    must be removed first. For that, we are going to use the Drill information as reference layer.  
    In this case the Drill data is delivered in Gerber format.  
 
7.  Load the ./drill.gbx as usual. 
     The loaded data is now displayed as ordinary gerber data without drill definition  
     (Hole View), as we saw with Exellon Drill data (See Figure 16) 
 
8.  Transfer the gerber layer into Drill data by executing the function:  
     Edit > Change gerber layer into Drill layer 
     Note: For layers with circle pads only.  
 
    A pop-up message will ask you to continue without having any Undo possibility,  
    choose Yes. 
    Now you can see the true drill holes as we used before. (See Figure 23) 
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Figure 23: Drill (Hole view) 
 
 
9.  Select one of the Via pads on the �Solder-mask layer�  to investigate the Aperture D-code 
     RMB > Report selected objects or {i}  ( D-code Via pad = D10  (1.216mm) ) 
 
10. Select all objects from the layer by RMB > Select All 
      to select only the Via pads we using the RMB > Select object with aperture 
      Pick the D-code from the list and OK. Verify visually if you select the via pads only ? 
     
      Delete them by RMB > Delete or {Del} 
 
Note:  If the �Select Aperture� list is empty, and all the D-code are D999, it will mean that 
          Viewplot has to Re-calculate the Apertures. This will occur if you copy objects from 
        One to another layer. Viewplot will generate the new apertures if you save the data  

to a gerber file. For saving data you need a valid license key.  
 
 
11. On top of the connector we will add some additional Solder-mask. 
      Using the techniques from above and the Add rectangle Pad function from the Tool-bar    
      should end up with the result shown in (Figure 24). Good luck. 
     
      Some hints: Switch grid by {Ctrl G} Refresh the window with {F5} and use the Auto pan    
      function within the add mode.  
 
 
Note: You can find the end result in Gerber format:  ./soldermask-result.gbx  
 

 
Figure 24: End result Solder-mask layer 
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Saving Data 
In addition to saving data in the internal Viewplot format, Viewplot also allows 
the output of RS-274-X, RS-274-D, NC Drill files, basic DXF, HPGL, Bitmap and PDF format.  
Viewplot can even export data to a Mentor Graphics Board-Station �do_file� format, which 
Can be easily loaded into Librarian as Board_outline. (See Board-Station Interface) 
For saving data a valid license file and key is required. (See Ordering info) 
 
We will now simply output a couple of RS-274-X files to illustrate the ability to translate data 
with Viewplot. For the demo we will translate the gerber input data to PDF format. 
 
1. Load all gerber data files from the ./274-X_gerber demonstration files {F3}. 
2. Select File > Save as 
3. Choose the PDF option and enter the output file name �output_data.pdf�. 
4. Select the layers that you wish to output from the �Export to PDF� window. 
5. You can change the output settings as Paper size, Orientation and Scale. 
6. Press the ok button to complete. 
7. Open the output pdf file, you will see that the files names are used as bookmark 
    to make navigating in the PDF file easy. 
 
8. The PDF file generated by Viewplot is a very accurate, you can zoom in to 1600% 
 
9. If you don�t have a valid license key, the output file can also be found in the  
    ./274-X_gerber dir �output.pdf� 
 
 

 
Figure 25: Export to PDF window 
 
You can save the gerber files also to one of the other formats, and change the  
specific file formats. 
 

Save Gerber data to PDF format  in batch mode 
Viewplot can also translate Gerber input directly to PDF format from command line, 
This to integrate Viewplot within your current design flow. 
A configuration file �pdfexport.txt� is used  to guide Viewplot through the translation. 
 
1. A example from the configuration file can be found in ./274-X_gerber directory  
    �pdfexport.txt� 
    Input files (Up to 32), Output pdf file name and formats must be defined here. 
    Optional information as Name, Organization, Title and Subject can be defined 
    and will be stored in the PDF output file as well. 
2. Run the batch process from command line by :Viewplot.exe /z pdfexport.txt 
3. You can find the results from the translation in the �ResultsFile� (Log file) 
4. After opening the PDF file you can find the Document properties by {Ctrl D}.  
 



Viewplot The Gerber Viewer Translator 
 

 

Viewplot Demo guide Roneda PCB Design Consultancy 20 

Board-Station Interface 
 
Viewplot can Export data to a Mentor Graphics Board-Station �do_file� format, which 
Can be easily loaded into Librarian as a Board_outline. 
With these you can translate mechanical information in DXF format directly into a  
Board Station �do_file�. The data Input can be in Auto-cad DXF and or Gerber or Drill format.   
Modifications can be made within Viewplot, and with the Export functionality 
File > Export to Mentor Bs the translating will take place.  
Lines, Arcs, Circles and Drill holes objects within Viewplot are supported. 
 
For Board Station users we can provide you with the Free user-ware, to configure an  
easy to use Interface between Viewplot and Mentor Graphics Board Station. 
A Mechanical Interface for Board_Outlines and drill hole information. 
And an Output process that integrates the batch PDF functionality within Fablink. 
 
 
We will now Export a DXF file in to a Board Station �Ample-file� to illustrate the ability to 
translate DXF data within Viewplot, and load the data in Librarian.  
 
 
1. Load the DXF mechanical data file from: ./DXF/board-outline.dxf demonstration files {F3}. 
2. You can add additional Drill holes. (See Viewplot manual for more info) 
3. File > Export to Mentor Bs (mil) to export to an �Ample-file� format. 
4. Select or enter the output file name in the �Save Mentor ample file� window.  
    (board-outline.bs) 
5. You can change the default line width in the Pop-up window, Set width to 0.2mm  
6. By pressing the Ok button the Output �Ample-file� is created. 
7. Now you can load the �Ample-file� in Librarian by use of Load Board Station File from  
    the Viewplot menu. (See Figure 26) 
8. Select the �Ample-file� by the navigator window and Ok. 
9. Previous board-outline will be moved to a temp layer, you will see the Board-outline 
    translated by Viewplot.  
 
 

 
Figure 26: Export to Mentor BS Ample-file process steps 
 
 
If you don�t have a valid license key, the �Ample-file� can also be found in the  
   ./DXF dir �board-outline.bs� 
 
Installation instructions and other information concerning the user-ware can be found in the 
Read-me files included with the user-ware. (For Viewplot users with a valid license key only) 
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Viewplot-batch within Fablink 
Now we will create our gerber data within Fablink and translate it without any extra steps 
to a PDF document that includes all the artwork data processed. 
For this we will provide you with some additional user-ware function to smoothen the 
complete output process. 
 
Normally you define your artwork order, and create the artworks, the artwork names are 
named in the order they where build in the artwork_order. (artwork_1 artwork_2 etc) 
 
With the Viewplot user-ware you can load a default artwork_order and, by using of an Xref list 
(The alias file)  you can pre-define the final artwork gerber names. 
The artwork_x names are renamed to the new names from the �Alias list�, and the final 
documentation set in high quality PDF format is created including the final artwork names. 
 
Lets start. 
 
1. Invoke Fablink from the sample design  ./Mentor/Demo_guide/Design, demonstration 

files. (See pix) 
 

 
Sample design; in Mentor Graphics 
 
 
2. Load the �Default� artwork order by the Viewplot menu (See Figure 27) 

Note: This will load a default Artwork order from the user-ware Env. 
       Select yes to override existing artwork_order. 
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Figure 27: Viewplot User-ware menu in Fablink 
 
 
3. Change this artwork order so it will fit to the specific needs from the Demo design 

like the way you used to do normally within Fablink. (See Figure 28)  
 

4. Setup the �Output aliases� by the menu pick (see Figure 27) and change this to 
       the design specific needs, (Delete artwork items there not exist, and update information  
       if needed)  
       (See Figure 29) for an example from the �Demo_guide� Design. 
 

 

  
Figure 28:       Figure 29: 
Change artwork order to fit to the Design  Output File mapping list (Alias) 
 
 
5. Create the artwork data files as normally is done within Fablink. 
 
6. Now we going to rename and move the artwork orders created by �Create artwork� 
      to the ./Demo_guide/output dir, and create the Design documentation from all the  
      artworks In one PDF document by Viewplot in batch mode. 
      This is done based on the �Alias file� Xref. Select from the Viewplot menu  
      �Viewplot gerber 2 PDF� (See Figure 26). 
 
7. After renaming the artworks a window �Viewplot Gerber to PDF� will pop-up where you 

can  select the Paper size(A1 to Letter(11 different formats)) and Orientation:  
      (Portrait-Landscape or Auto).  
      Including an option for �Fit to Page� and a View option, if view is on, the created output 
      PDF doc: �Demo_guide.PDF� will be opened within acrobat reader in background.  
      (see Figure 30) 
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Figure 30: Pop-up window for Viewplot settings 
 
 
8. If you have a look in the ./Output dir you will find the renamed gerber files, the PDF 

document created by Viewplot, and some additional files as the Viewplot log-file �*.log� 
the Viewplot batch config file: �pdfexport.txt� and a index.txt file. 

      The index file is an overview from all the renamed artworks and their description. 
 
9. If you don�t have a valid license key, the output data generated can also be found in the 
      ./Demo_guide//Output dir. 
 
10. To start Viewplot within Fablink directly from the Design/output dir press {Ctrl v} 
 
 

Start Viewplot with selected files 
 
The last function from Viewplot that is integrated within Fablink is to open 
Gerber files selected from the Design/output dir by a menu-pick 
 
1. Execute the function �Load gerber in Viewplot� by the Viewplot menu (See Figure 27) 
 
2. Select the Gerber files you want to Investigate within Viewplot and Ok. (See Figure 31) 

Viewplot will now be invoked with the selected files as background process. 
 

Note:  Start Viewplot with selected files is also available from command line 
See the Viewplot manual for more info. 

 
 

 
Figure 31: Select the Gerber files to load within Viewplot 
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Conclusion 
This demonstration guide for Viewplot has only scratched the surface of 
what can be achieved with the tool. Feel free to investigate further on your own and be sure to 
let us have any constructive feedback so that we can continually improve the products. 
Thanks for your time. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Legal Stuff: 
Mentor Graphics, Board Station, Fablink & Librarian are either registered trademarks or trademarks of Mentor 
Graphics Corporation (MGC) in the United States and/or other countries�Windows, Windows 2000 and Windows NT 
are trademarks of Microsoft Corporation. 
Adobe(TM) , PostScript(TM) , PDFare registered trade marks of Adobe systems Inc. 
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